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1. Scope
This document describes the test plan for verifying the design of DDish, as described
in DDish.01. It provides the necessary procedures for the validation test of the device.

2. Reason for Re-issue
	ISSUE
	REASON FOR RE-ISSUE

	1
	This is the first time the plan has been issued



3. Introduction

3.1. Description
The following test will be performed:
	Test Case
	Direct Requirement
	Test

	
	
	Dimensional Testing

	010
	REQ130, REQ170, REQ180
	Dimensions of the Electrode Assembly

	
	
	Whole System Testing

	020
	REQ110-210
	Cytocompatibility Testing

	030
	REQ320, REQ430-450, REQ520
	Electrical Parameter Testing



3.2. Strategy
The DDish is a new product. All tests will be conducted for validation.

4. Applicable Documents
This plan is based on requirements from DDish.01 DDish Functional Requirements.

5. Definitions

PCB: Printed Circuit Board
CFI: Contractile Force Indicator
The Contractile Force Indicator is a well plate insert utilized by the Tissue Innervation and Muscle Mimetics Laboratory at NJIT designed to measure the contractile force generated by muscle tissue constructs in vitro. 
Cytocompatibility: 
	A material/system is considered cytocompatible if both the structure and functions of the tissue in direct contact with it remain unchanged. The maintenance of these functions depends directly upon the quality of the material surface.
System Modularity:
	This relates to granting DDish operators the freedom to choose electrical parameters (voltage, frequency, and duty cycle) within specified ranges and preferred rows for stimulation. 
Frequency:
	An expression of how frequently a periodic waveform or signal repeats itself at a given amplitude.
Duty Cycle:
	Percentage of a signal’s ON time (high voltage); i.e a 60% duty cycle signal is ON for 60% of the time and OFF for 40%. 
Cell Confluency: 
	The percentage of the surface area within a well that is covered by a layer of cells in culture.

6. Setup

This testing requires the following units as a minimum:
a. The DDish Device:
i. Electrode assembly
ii. Adafruit MCP4728 DAC
iii. Arduino UNO R3
b. Computer with Arduino IDE Software
c. 24-Well Plate
d. GW Instek Oscilloscope
[image: ]
Figure 1: Testing Setup for Validating the DDish Device

7. Equipment Record
The following test equipment, or equivalent, is needed to execute the tests in this plan.
	Item
	Model Number(s)
	Calibration Required?

	Computer (any OS)
	Varies
	No

	The DDish Device
	N/A
	No

	GW INSTEK Oscilloscope
	 GDS-2102
	Yes

	Digilent BNC to Alligator Clip Cable
	240-134
	No

	Fisherbrand 24 Well Plate
	142475
	No

	Gibco DMEM (non-supplemented)
	A1443001
	No

	Live Cells (Tissue Constructs)
	TIMM Lab - NJIT
	No

	(10) Contractile Force Indicators (CFI) 
	TIMM Lab - NJIT
	No

	(1) Uline Transfer Pipettes - 5 mL
	S-24319
	No

	AmScope Biological Microscope
	B400
	No

	Fisherbrand Cell Culture Incubator
	TCWCO2
	No

	Digital Caliper
	N/A
	Yes

	(2) Adafruit Small Alligator Clip Test Lead
	1528-1789-ND
	No

	(1) UltraPure™ Ethidium Bromide, 10 mg/mL
	15585011
	No

	(1) Rainin Classic Pipette PR-1000
	17008653
	No































8. Test Cases

Test Case 010: Dimension of Electrode Assembly

Purpose: To verify the dimensions of the electrode assembly component in the DDish

Specification: 
Direct Specification Source: DDish.01 [REQ130, REQ170, REQ180]

Test Architecture:
[image: ]
Figure 2: Digital Caliper Diagram with Labeled Components
[image: ]
Figure 3: Engineering Drawing of PCB with Dimensions

Equipment:
1. Digital caliper (metric units with significant digits to one hundredth of a millimeter)

Test Procedure:
1. Turn on the digital caliper.
2. With the jaws closed, press the ZERO button on the caliper and wait for the display to read zero.
3. Using the caliper, record each figure-referenced dimension in one of the two following ways:
a. For internal dimensions (i.e. inside diameters), use the internal jaws.
b. For external or surface distances (i.e. lengths), use the external jaws.

Expected Results:
Test passes if the following occurs:
4. Measurements are within the specified tolerances as described in the Test Results Table of Test Case 010 Dimensional Measurements (Figure 3).



Test Results:
	Item
	Expected Results
	Test Results
	Pass/Fail

	PCB Length
	A = 118 mm ± 2%
	A = 117.21
	Pass

	PCB Width
	B = 76 mm ± 2%
	B = 76.32
	Pass

	Electrode to PCB Width Distance
	C = 10 mm ± 2%
	C = 10.13
	Pass

	Cutout Opening Width
	D = 8.75 mm ± 2%
	D = 8.79
	Pass

	Horizontal Distance between Electrodes
	E = 19 mm ± 2%
	E = 18.99
	Pass

	Vertical Distance between External Wire Holes
	F = 2.5 mm ± 2%
	F = 2.57
	Pass

	Cutout Opening Length
	G = 110 mm ± 2%
	G = 110.56 
	Pass

	External Wire Hole to PCB Width Distance
	H = 1.5 mm ± 2%
	H = 1.53
	Pass

	Vertical Distance between Electrodes
	I = 11 mm ± 2%
	I = 11.34
	Pass

	Electrode to PCB Length Distance
	J = 4 mm ± 2%
	J = 4.15
	Pass

	Vertical Distance between Anode Electrodes
	K = 8 mm ± 2%
	K = 7.96 
	Pass

	Vertical Distance between Cathode Electrodes
	L = 8 mm ± 2%
	L = 8.12
	Pass

	Electrode Length
	M = 18 mm ± 2%
	M = 17.93
	Pass

	Electrode Diameter
	N = 1 mm ± 2%
	N = 1.01
	Pass


Table 1: Test Results of Test Case 010 - Dimensional Measurements






Test Case 020: Cytocompatibility Testing
Purpose: To verify that the DDish is non-toxic to tissue constructs in a 24-well plate

Specification: 
Direct Specification Source: DDish.01 [REQ110-210]

Test Architecture:
[image: ]
Figure 4: Setup for DDish Cytocompatibility Testing
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Figure 5: Cell Culture Incubator Setting Interface and Power Switch

[image: ]
Figure 6: Removing and Adding Cell Medium from 24-Well Plate

[image: ]
Figure 7: AmScope Biological Microscope Guide
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Figure 8: Ethidium bromide (EtBr) Staining of Cells Post-Stimulation

[image: ]
Figure 9: Placement of DDish Electrode Assembly on 24-Well Plate
[image: ]
Figure 10: ImageJ Cell Detection Software with Counting Mask

[image: ]
Figure 11: Signs of Oxidation and Moisture Formation on PCB

Equipment: 
1. Computer (any OS)
2. “DDish.ino” Arduino IDE Sketch
3. ImageJ (Fiji) Software
4. Live C2C12 Mouse Myoblast Cells
5. Gibco DMEM (non-supplemented)
6. (1) Rainin Classic Pipette PR-1000
7. Electrode Assembly (DDish)
8. Fisherbrand 24-Well Plate
9. Fisherbrand Cell Culture Incubator 
10. AmScope Biological Microscope
11. (1) UltraPure™ Ethidium Bromide, 10 mg/mL
12. Deionized (DI) Water (30mL)

Test Procedure:
1. Turn on the cell culture incubator flipping the power switch and ensure that it is set to 37oC and 5% CO2, by entering the parameters in the touch user interface, as shown in Figure 5.
2. Place a CFI insert in each of the nine wells shown in Figure 4 and Figure 9.
3. Culture C2C12 mouse myoblast cells in Gibco DMEM in the nine wells shown in Figure 4, then place the 24-well plate in the incubator for 24 hours.
4. Using the pipette, discard the old DMEM and add approximately 700 μL of fresh DMEM to each of the 9 wells using a Rainin Classic Pipette PR-1000, as shown in Figure 6.
5. Place the electrode assembly on top of the well plate, as shown in Figure 9.
6. Place the 24-well plate in the incubator.
7. Open Arduino IDE on the computer and run the “DDish.ino” sketch provided.
8. Enter electrical parameters and selected rows as follows:
a. Voltage of 0.25V, frequency of 0.25Hz, and duty cycle of 12.5%.
b. Turn on Row 1. Switch Row 2, Row 3, and Row 4 off.
9. Enter a time duration of 120 minutes.
10. Once this stimulation has elapsed, the Arduino IDE Serial Monitor will provide a prompt for new parameters. Enter the electrical parameters and selected rows as follows:
a. Voltage of 0.25V, frequency of 0.25Hz, and duty cycle of 12.5%.
b. Turn on Row 1 and Row 2. Switch Row 3 and Row 4 off.
11. Once this stimulation has been completed, apply the UltraPure™ Ethidium Bromide (EtBr) to all nine wells and leave it to stain for 30 minutes (Figure 8). 
12. After 30 minutes, destain the 9 wells with fresh DI water for 15 minutes with gentle agitation. 
13. Connect the AmScope Biological Microscope to a computer using the USB connector and open the AmScope Software (Figure 7).
14. Disconnect the well plate from the control system wiring and place it under the objective 10x lens. Line up the view with the wells that the cells are in. Use the coarse adjustment and fine adjustment knobs to focus the slide, as shown in Figure 7. Take and save five images of each well onto the computer by clicking the “Snap” button on the top left (Figure 7).
15. Open ImageJ and select “File” > “Open”, then select the first image for quantification (Figure 10).
16. Select “Image” > “Adjust” > “Color Threshold”  and adjust the scales in the pop-up window until the image appears clear (Figure 10).
17. Select “Analyze” > “Analyze Particles” > “Show: Ellipses” and press “OK” (Figure 10). Record the number that appears in the “Summary” pop-up window.
18. Compare the number of dead (red) cells in the images before and after the placement of the electrode assembly to assess the cytotoxicity of the DDish. 
a. Cell viability % is calculated by:

19. Observe if there are any signs of oxidation and moisture formation on the DDish Electrode Assembly (Figure 11).

Expected Results:
Test passes if the following occurs:
1. After exposure to the device and prolonged electrical stimulation, cell viability is at least 95%.
2. The electrode assembly is free of oxidation and moisture formation.

Test Results:
	Item
	Expected Results
	Test Results
	Pass/Fail

	Cell Viability
	For all study groups, average cell viability percentages determined through EtBr staining are at least 95%
	Average (n=3) cell viability of Row A 
(3 hours of electrical stimulation) was 98.8%.
	Pass

	
	
	Average (n=3) cell viability of Row B 
(1 hour of electrical stimulation) was 99.1%.
	Pass

	
	
	Average (n=3) cell viability of Row C 
(no stimulation) was 98.9%.
	Pass

	Electrode Assembly Stability
	No visual signs of oxidation and moisture formation on the PCB and electrodes. 
	After 3 days in the incubator, there were no visual signs of oxidation or corrosion on the PCB and electrodes.
	Pass


Table 2: Test Results of Test Case 020 - Cytocompatibility Testing

[image: ]
Figure 12: 10x Representative Images of C2C12 Cells Stained with EtBr

Test Case 030: Electrical Parameter Testing 
Purpose: To verify that the DDish can deliver signals with voltages of 0.25-5 V, frequencies of 0.25-15 Hz, and duty cycles of 10-95% to tissue constructs in a 24-well plate 
 
Specification: 
Direct Specification Source: DDish.01 [REQ320, REQ430-450, REQ520]

Test Architecture:
[image: ]
Figure 13: Test Architecture for Electrical Parameter Testing
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Figure 14: Contractile Force Indicators in 24-Well Plate
[image: ]
Figure 15: Placement of DDish Electrode Assembly on 24-Well Plate
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Figure 16: GW INSTEK Oscilloscope Interface and Power Switch

[image: ]
Figure 17: Arduino IDE Sketch Start Up

[image: ]
Figure 18: Arduino IDE Serial Monitor Input
[image: ]
Figure 19: Voltage, Frequency, and Duty Cycle Readings on GW INSTEK Oscilloscope

Equipment:
1. Computer (any OS)
2. Gibco DMEM (non-supplemented)
3. Electrode Assembly (DDish)
4. Fisherbrand 24-Well Plate
5. (6) Contractile Force Indicators (CFI)
6. GW INSTEK Oscilloscope
7. (1) Uline Transfer Pipette - 5 mL
8. Digilent BNC to Alligator Clip Cable
9.  (2) Adafruit Small Alligator Clip Test Lead
10.  AmScope Biological Microscope

Test Procedure:
1. Place a CFI insert in each of the six wells within a single row of a 24-well plate (Figure 14).
2. Using the pipette, discard the old DMEM and add approximately 1.5 mL of fresh DMEM to each of the six wells using a Uline transfer pipette, as shown in Figure 6. 
3. Place the electrode assembly on top of the well plate, as shown in Figure 15.
4. Verify that the Arduino is connected to the computer using its USB cable connection and run the provided Arduino IDE sketch by pressing the Upload button and turning on the Serial Monitor, as shown in Figure 17.
5. When prompted by the Serial Monitor, as shown in Figure 18, input the parameters as follows: 
a. For voltage testing:
i. Input 1Hz, 50% duty cycle, 0.25V, 60 minutes, and turn on stimulation for the selected row using the input window shown in Figure 18. 
ii. Adjust the horizontal and vertical scale control for Channel 1 to achieve 2-3 waveforms on the display.
iii. Record the voltage value shown by ‘Vhi’ on the oscilloscope after the waveform has filled the display screen (Figure 19). Next, move the Adafruit Small Alligator Clip Test Leads to the solder points of the positive and ground electrodes for the sixth well in the selected row and record ‘Vhi’ (Figure 19). Take the average of the two measurements using the equation below.  
iv. Turn off the switch and then turn it back on. Input 1Hz, 50% duty cycle, 5V, 60 minutes, and turn on stimulation for the selected row using the input window shown in Figure 18. 
v. Adjust the horizontal and vertical scale control for Channel 1 to achieve 2-3 waveforms on the display.
vi. Record the voltage value shown by ‘Vhi’ on the oscilloscope after the waveform has filled the display screen (Figure 19). Next, move the Adafruit Small Alligator Clip Test Leads to the solder points of the positive and ground electrodes for the sixth well in the selected row and record ‘Vhi’ (Figure 19). 
vii. Take the average of the two measurements using the equation below.
 
b. For frequency testing:
i. Input 0.25Hz, 50% duty cycle, 2V, 60 minutes, and turn on stimulation for the selected row using the input window shown in Figure 18. 
ii. Adjust the horizontal and vertical scale control for Channel 1 to achieve 2-3 waveforms on the display.
iii. Record the frequency value shown by ‘Frequency’ on the oscilloscope after the waveform has filled the display screen (Figure 19). Next, move the Adafruit Small Alligator Clip Test Leads to the solder points of the positive and ground electrodes for the sixth well in the selected row and record ‘Frequency’ (Figure 19). Take the average of the two measurements using the equation below. 
 
iv. Turn off the switch and then turn it back on. Input 15Hz, 50% duty cycle, 2V, 60 minutes, and turn on stimulation for the selected row using the input window shown in Figure 18. 
v. Record the frequency value shown by ‘Frequency’ on the oscilloscope after the waveform has filled the display screen (Figure 19). Next, move the Adafruit Small Alligator Clip Test Leads to the solder points of the positive and ground electrodes for the sixth well in the selected row and record ‘Frequency’ (Figure 19). Take the average of the two measurements using the equation below. 
 
c. For duty cycle testing: 
i. Input 1Hz, 10% duty cycle, 3V, 60 minutes, and turn on stimulation for the selected row using the input window shown in Figure 18.
ii. Adjust the horizontal and vertical scale control for Channel 1 to achieve 2-3 waveforms on the display.
iii. Record the duty cycle value shown by ‘DutyCycle’ on the oscilloscope after the waveform has filled the display screen (Figure 19). Next, move the Adafruit Small Alligator Clip Test Leads to the solder points of the positive and ground electrodes for the sixth well in the selected row and record ‘DutyCycle’ (Figure 19). Take the average of the two measurements using the equation below. 
 
iv. Turn off the switch and then turn it back on. Input 1Hz, 95% duty cycle, 1V, 60 minutes, and turn on stimulation for the selected row using the input window shown in Figure 18. 
v. Record the duty cycle value shown by ‘DutyCycle’ on the oscilloscope after the waveform has filled the display screen (Figure 19). Next, move the Adafruit Small Alligator Clip Test Leads to the solder points of the positive and ground electrodes for the sixth well in the selected row and record ‘DutyCycle’ (Figure 19). Take the average of the two measurements using the equation below. 
 

Expected Results:
Test passes if the following occurs:
1. The average output voltage value between the first and sixth well for each stimulation varies by less than 2% from the input voltage.
2. The average output frequency value between the first and sixth well for each stimulation varies by less than 2% from the input frequency.
3. The average output duty cycle value between the first and sixth well for each stimulation varies by less than 2% from the input duty cycle. 

Test Results:
	Item
	Expected Results
	Test Results
	Pass/Fail

	Minimum Voltage (1V) Stimulation
	0.25 V (± 2%)
	0.25 
	Pass

	Maximum Voltage (5V) Stimulation
	5 V (± 2%)
	4.96
	Pass

	Minimum Frequency (1Hz) Stimulation
	0.25 Hz (± 2%)
	0.25
	Pass

	Maximum Frequency (10Hz) Stimulation
	15 Hz (± 2%)
	14.81
	Pass

	Minimum Duty Cycle (25%) Stimulation
	10% (± 2%)
	9.97
	Pass

	Maximum Duty Cycle (75%) Stimulation
	95% (± 2%)
	9.97
	Pass


Table 3: Test Results of Test Case 030 - Electrical Parameter Testing













9. Attachments
Cover sheet for QUALITY RECORDS
	Test Plan Name
	DDish.01

	Test Engineer (s)
	Team 11 

	Test Date
	04/29/2024

	Version
	(HW)		(SW)

	System Name
	D-Dish

	Tests covered
	

	MRs written?
	Yes	or	No   [See next page]

	Data Attached?
	Yes	or	No

	Old Results appended?
	Yes	or	No

	Record Type
	System Test Results

	Date Filed
	04/29/2024

	Storage Location (Room #)
	

	Approval Signature(s)
	






TEST STATUS
	Test Case
	Test Passed?
	IT Test Failed MR#
	IF TEST FAILED, MR
NOT ENTERED
REASON
	COMMENT

	010
	 Yes
	N/A
	
	All test results within the expected range. 

	020
	Yes
	N/A
	
	All test results within the expected range. 

	030
	Yes
	N/A
	
	All test results within the expected range. 
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